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Starting a New Project

1. Create Project name.drn (the extension .DRN is the same as the seed file for a .DSN file). Open the
.DRN file in MicroStation. Another option is to create a new model in the .dsn file.

2. Start Geopak by going to Applications>GEOPAK-> Activate GEOPAK. With Geopak running go to
Applications>GEOPAK - DRAINAGE- Drainage.
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The DRAINAGE tool box will open. The heading Drainage will be added to the Main Menu.

ﬂ DRAIMAGE - Untitled - [Mo Active Metwork] | 28 |

| Project Component  Network Reports  Utilities  Tool Boxes |
3. On the DRAINAGE toolbox go to Project>New

ﬁ DRAINAGE - Untitled - [Mo Active Metwork] | 28 |

| Project | Component  MNetwork Reports  Utilities Tool Boxes |

e =

Open... |

OR

On the Main Menu go to Drainage—>Project->New

-— = = — — =

File Edit Element Settings Tools Utilities Workspace Applications | Drainage | Window Bidltems Help Axiom »@ v | |Level 1

E'@'E'@'@vgﬁvg‘v:\hvﬁ],@ﬂ Project v Mew.. ‘

Component 2 Onen... |

The browser window will open:
e Pick the project location in ProjectWise.

e File Name: type the ProjectName/Number.gdf. The GDF (Geopak Drainage File) is where
information will be stored.

e Click Save
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Setting Preferences

With the project open, go to Project->Preferences

H DRAINAGE - Cheslea Creek.gdf - [Mo Active Network] ‘

Project | Component Network Reports  Utilities  Tool Boxes

Dpen...
Save
Save As...

Preferences

Drainage Library

The Preferences window will appear. Go to File>Open and browse to the Preferences.dpf file located in
the PWMain\Documents\Standards\RoadDesign\Civil\Drainage\ folder. This file presets several

Preferences settings.
e oo L
File

Open... Drainage Library File {DLB):

Units

Use this dialogue box to set the appropriate units for the project. The Preferences.dpf file sets the
"
-H Preferences - Units
File

units to English as the default.
- = |
Options |

Units @ English ©) Metric

Prqjed Componernts Drainage Area = Acres

Rainfall Parameters Length = Feet

Land Use Options Dimension = Fest

Frequency Options Depth = Feet

Intensity Option Discharge = Cubic Feet per Second

Drainage Area = Hectares

Length = Meters

Dimension = Meters

Depth = Meters

Discharge = Cubic Meters per Second

Junction Logses
Inlet Options
Mode Options
Link Options
Profile Options
Plan Symbology
lpdates

Save Options

[k ] [ Cancd |

Velocity = Feet per Second
Intensity = Inches per Hour

Welocity = Meters per Second
Intensity = Milimeters per Hour
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Project Components

Use this dialog box to define the location of the files required for a project. Fill in the items shown and
leave the others blank.

Options Drainage Library File (DLB): | pw:\Standards'\RoadDesign\CivinDi | &

Units
Froject Components GPK Job Number: | 122 Q

Rairfall Parameters Drainage Cell Library: | pw:*5Standards*RoadDesignMicrost
Land Use Options
Frequency Options
Intensity Option DDBE: *Standards \RoadDesignCivilsCh
Junction Losses

Criteria Directany:

Node Options Superelevation Shapes File: “\Projects’ 1712201007 Design™.1
Link Options
Profile Cptions Site Project:

Plan Symbology Criginal Ground

Updates TINFle = “\Projects\ 1712201007 \Photo\ 1
Save Options

Design Surface
TINFile  v] |pw:\Projects\1712201007\Design\1

Q
Q,
Q,
Inlet Cptions Water and Sewer Project : Q,
Q
Q@
Q,
Q,

| 0K | |Cance||

Drainage Library File (DLB):
PWMain\Documents\Standards\RoadDesign\Civil\Drainage\Drainage_library.dlb. This is preset
by the Preferences.dpf file. The Drainage_library.dlb file contains rainfall intensity tables specific
to the lowa DOT, and land use tables. It also contains settings for nodes (intakes, junctions, and
aprons) and links (pipes) specific to the lowa DOT. It also contains spread sections that can be
created by designers. The Drainage_library.dIb file can be accessed by going to
Project->Drainage Library.

1Emjeu:1 Componert Metwork Reports  Lhilties Tool Boxes

Mew...
Qpen...
Save
Save fs...

Preferences
|_Q1E|inage Library

The following dialogue box will appear:
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Fil=  Edit

| Rainfall | Land Use " Nodes " Links " Spread Section |

Blement |0 Description
Region 5 Southeast lowa
Region & South Central lowa
Reqgion 7 Southwest lowa
Region & East Central lowa
Region 5 Certral lowa
Region 4 West Central lowa
Region 3 Mortheast lowa
Region 2 Morth Central lowa
Region 1 Morthwest lowa

Designers can make changes to the Drainage_library.dlb file to suit their projects’ needs, e.g. if a
modified intake is needed. If changes are made, save the file to the project folder by going to
File->Save As, and under Project Components, reference this file for Drainage File Library (DLB).

New... Spread Section
Cpen...
Description
Save
Southeast lowa
| Savefs. | Souin Certral lowa 2

GPK Job Number: Select the project GPK. This allows intakes to be located by station and
offset.

Drainage Cell Library:
PWMain\Documents\Standards\RoadDesign\Microstation\Cells\dsnDrainage.cel. This file
contains the cells for all intakes, junctions, and aprons. This is preset by the Preferences.dpf file.
Designers can make changes to the dsnDrainage.cel file to suit their projects’ needs, e.g. if a
modified intake is needed. If changes are made, save the file to the project folder, and under
Project Components, reference this file for Drainage Cell Library.

DDB: PWMain\Documents\Standards\RoadDesign\Civil\Drainage\Drainage.ddb. This file is used
to calculate quantities by D&C Manager based on symbology. This is preset by the
Preferences.dpf file.

Original Ground: Set to TIN File and the select project TIN file from the
PWMain\Documents\Projects\(Project Directory)\Photo folder. This TIN is usually created by
Survey or Photogrammetry

Design Surface: Set to TIN File and select the proposed TIN. If the project does not involve a
proposed TIN file, select the project TIN as the design surface. This TIN file is created by the
designer.

Note: GPK Job Number, Original Ground, and Design Surface do not need to be filled in to
use Geopak Drainage. Filling these in allows designers to locate structures by station and
offset (see Section 4A-53) rather than typing the information in. Original Ground and Design
Surface can be added in later if they become available.
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Chapter 4—Drainage

Section 4A-52—Starting a Geopak Drainage Project

Rainfall Parameters

Use this dialog box to select the appropriate region the project is located in.

F |

File
Options
Urits Rational Method
Project Components {Rainfall Source:; [Hegiun 1 T]
Rainfall Parameters
Land Use Options SCS Method
Frequency Options ) ] = -
Intensity Option Rainfall Source: [None Available ]
Junction Losses @ Antecedert Moisture Condition |
Inlet Options (7 Antecedent Moisture Condition 11
Node Options @ Antecedert Moisture Condition IlI
Link Options -
Profile Options Hydrograph Time Interval: | 0.000
Plan Symbology
|pdates
Save Options
| 0K | | Cancel |

Rational Method/Rainfall Source: Select the appropriate lowa Sectional Code using Table 2 of
Section 4A-5.

SCS Method: This is an alternative to the Rational Method and typically is not used by the Office

of Design.

Land Use Options

This dialog box allows designers to choose a table which will assign runoff coefficient values to
specific land types defined by line symbology. The Office of Design hasn't yet developed its own land
use symbology tables for drainage. Designers can skip this dialogue box.

File
T Rational Method
T @ Single Land Use tem:  [Table 3- ASCE/WPCF |
Project Components () Multiple Land Use tem: .
Rairfall Parameters Land Use ltem | Level J_Cu:ulc:ri"-".n'eigl'rt Style |
Land Use Options
Frequency Options
Imtensity Option
Junction Losses r .
Inl=t Options Sample Land Use ~ | Symbology:
MNode Options SCS Method
Link Options (@ Single Land Use ftem: E[TabIEB-ASCE.-’WF‘CF - ]
Profile Options (71 Muttiple Land Use kem:
Plan Symbology PP,
Updates Land Use ltem | Level J_CDlCIFJ_:.I'EIgl‘It Style |
Save Options
| OK | | Cancel | Table 3-ASCEAWPCF = | Symbology:
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Chapter 4—Drainage

Section 4A-52—Starting a Geopak Drainage Project

Frequency Options

Use this dialog box to select the appropriate recurrence interval (frequency).

7
=

File
Options
Units Drainage Library (DLB): .. \Geopak'Drainage"Drainage_library.dib
Project Components Rational Frequency Options
Rainfall FE"E'"'!HE"S Computation Runoff Coefficient
Land Use Options Frequency: Peaking Factor:
Frequency Optiong
Intensity Option 10 Year 1.0000
Junction Losses )
Inlet Options SCS Frequency Options
MNade Options Cumulative Runoff Coefficient
Link Options Frequency: Peaking Factor:
Profie Optons ) [1o0
Plan Symbology
|Updates
Save Options

| oK | | Cancal |

Rational Frequency Options/Computation Frequency: Refer to Table 4 of Section 4A-5 to
select the appropriate frequency.
Rational Frequency Options/Runoff Coefficient Peaking Factor: This is used to compensate

for reduced infiltration during less frequent, higher intensity storms. The runoff coefficients of
Table 1 in Section 4A-5 already account for this, so set the Runoff Coefficient Peaking Factor to

1.0.
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Intensity Option
Use this dialog box to select intensity computations.

r
File
Options
Urits Drainage Library (DLB): .. \Geopak'Drainage™Drainage_library.dlb
Prqject Companents Minimum Time of Concentration: | 5.0000
Rainfall Parameters
Land Use Cptions Accumulate Pipe Fow Time by: [ Full Flow Velocity -|
Frequency Options ) i
T e Irrtensrt;.r Options .
Junction Losses (@) iCompute Intensity from Library Rairfall Data Source:
Inlet Options () Absolute Intensity: | 0.0000
Eﬁieoopﬁzﬁgs [] Weight Time of Concentration
Prafile Options )
Plan Symbology Inlet Computation Onhy
Llpdates - M sy
Save Options [T] Absclute Intensity: | 0.0000
| Ok | | Cancel |

Minimum Time of Concentration: The Preferences.dpf file sets this to 5 minutes, the minimum
allowed by the Office of Design.

Accumulate Pipe Flow Time by:
Uniform Flow Velocity: Velocity associated with normal flow is used to establish travel time.

Full Flow Velocity: Velocity associated with full flow is used to establish travel time. This is
the procedure followed in Section 4A-10. The Preferences.dpf file defaults to this option.

Iterative Velocity: Geopak Drainage makes three passes up and down the network
performing runoff and hydraulic calculations. This option provides the most accurate results.

Intensity Options:

Compute Intensity from Library Rainfall Data Source: The Preferences.dpf file defaults to
this option — rainfall intensities are already defined in the Drainage Library.

Absolute Intensity: This option allows the designer to override the Drainage Library and
input a desired rainfall intensity. This is option is not used by the Office of Design.

Weight Time of Concentration: Allows the designer to weight times of concentration when
combining different types and times of concentration so that the discharge will not decrease.
This option is not used by the Office of Design.

Inlet Computation Only/Absolute Intensity: Allows designers to override the Drainage Library
and input a desired rainfall intensity. This option is not used by the Office of Design.
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Junction Losses

This dialog box sets the equations and loss coefficients used in link (pipe) hydraulic calculations.

M Preferences - Junction Losses - Elﬂlﬂ
File
Options Disable All Junction Loss Computations
Units .
Loss Velocity: |Actual -
Project Components ss Velocty
Rairfall Farameters Description Loss Coefficient - K
Land Use Options o o
Frequency Options = Pressure Expansion: | 1.0000
Imengw Option — Free Surfface Expansion: | 1.0000
Junction Losses o
Inlet Options = Pressure Cortraction: | 0.5000
Mode Optiong s
Link Options +—— Free Surface Contraction: | 0.5000
Profile Options oo _
Plan Symboloqy T Bend Loss: |Method 1
Updates [+ Temminal Inlet/unction: | 1.0000
Save Options
1 F Simple Junction: |Method 2 -
[ oK | [Cancel| L F Complex Junction’ (Method 2 ]

Disable All Junction Loss Computations: The Preferences.dpf file toggles this on as a default.
Leave toggled on when performing preliminary design. Toggle off when doing final design.

Loss Velocity: Allows designers to choose if losses will be based on actual flow or full flow. For
final design, set this to Actual.

Pressure Expansion: Loss coefficient for pressure (full flow) expansions within the system, e.g
where a pipe flows into a structure. The Preferences.dpf file sets this to 1.0.

Free Surface Expansion: Loss coefficient for free surface (partial flow) expansions within the
system, e.g. where a pipe flows into a structures. The Preferences.dpf file sets this to 1.0.

Pressure Contraction: Loss coefficient for pressure (full flow) contractions within the system,
e.g. where a structure flows into a pipe. The Preferences.dpf file sets this to 0.5.

Free Surface Contraction: Loss coefficient for free surface (partial flow) expansions within the
system, e.g. where a structure flows into a pipe. The Preferences.dpf file sets this to 0.5.

Bend Loss: Method for computing bend losses. The Preferences.dpf file sets this for Method 1.

Terminal Inlet/Junction: Loss coefficient for terminal inlets or junctions with no upstream pipes.
The Preferences.dpf file sets this to 1.0.

Simple Junction: Method for computing junction losses at simple junctions — one pipe in and
one pipe out. The Preferences.dpf file sets this for Method 2.

Complex Junction: Method for computing junction losses at complex junctions — multiple pipes
in and only one pipe out. The Preferences.dpf file sets this for Method 2.
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Inlet Options
Use this dialog box to set the defaults for use in the Node Configuration Properties dialog.

F

File

Options
LUnits
;r;ﬁjl%:;pr:;zris Link By Pass Flow Options: [ Do Mot Allow Inlet By Pass in Link Discharges = |
Land Use Options Default Spread n Value: | 0.0160
Frequency Options
Intensity Option [] Bdend Superelevation Shapes to Inlet at Shape Slope
Junction Losses
Inlet Optiong
Mode Options
Link Options
Profile Options
Flan Symbology
Updates

Save Options

Inlet By Pass Options: | By Pass as Total Discharge = |

| OK | | Cancel |

Inlet By Pass Options: The Preferences.dpf file sets this to By Pass as Total Discharge. This
will set bypass flow as the difference between total discharge to the intake and intake capacity.
By Pass as C x Area Product expresses bypass from an intake as a product of runoff coefficient
and area. This product is added to the composite runoff coefficient and area for the next
downstream intake.

Link By Pass Flow Options: The Preferences.dpf file sets this to Do Not Allow Inlet By Pass in
Link Discharges. This option will design links (pipes) based on all the flow coming into the intake
(i.e. 100% capture). Allow Inlet By Pass in Link Discharges will design links (pipes) based on
calculated flow captured by the intake.

Default Spread n Value: This Preferences.dpf file sets this to 0.016. Typically, pavement
determination is not known, so use n = 0.016. If pavement determination is known, see Table 2

of Section 4A-6 to determine n.
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Node Options
Use this dialog box to set the node defaults and options.

T

File

Options |
LUnits

Egﬁ:@?:ﬂ?;:;ﬂ [[7] Scale Mode Cells ~ Scale Factor: | 1.0000
Land Use Options Minimum Freeboard: | 0.0000
Frequency Options
Imtensity Option
Junction Losses
Inlet Options

Mode Options

Link Options
Profile Options
Plan Symbology
Updates

Save Options

Defautt Mode |0 Prefoc: | -

| oK | | Cancel |

Default Node ID Prefix: A prefix can be typed in here that will be added to each node. The
Preferences.dpf file sets the prefix as I-. A number will be added to the prefix when the node is
defined. Subsequent nodes will be numbered sequentially.

Scale Node Cells: Allows designers to scale nodes with a specified scale factor such that node
cells can use standard node dimensions, while the cells are scaled in plan view. Leave this
toggled off

Minimum Freeboard: Freeboard is measured from the hydraulic grade line (HGL) to the intake
elevation. The Preferences.dpf file sets this to 0.0. This will trigger a warning message that the
HGL has exceeded the intake elevation.
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Link Options

Use this dialog box to set link (pipe) defaults and options.

M Preferences - Link Options - ‘ Eli‘éj

Rainfall Parameters
Land Use Options

File

Optians Default Link 1D Prefoc: | P-

lUnits Link Profile Options

Project Components Design Optimization: [ Minimize Depth of Cover |

Elewvation Option: |at Actual Link End  «

Frequency Options Link Design Options

Irltens.rt:.' Option () Design for Maximum Capacity

Junction Losses _ . .

Inlet Options @ Design for Full Capacity

Node Options (") Design Partial Capacity {d/D) Ratio: | 1.0000
Link Options (7 Design Partial Capacity (3/Q) Ratio:  1.0000
Profile Options ) ) -

Plan Symbology Link Slope Decimal:
Updates Link Criteria File

Save Options

File Name: Q

Hydraulic GradeLine Options
Hydraulic Gradsline Basis: [Equal Hydraulic Gradsline ~ |

Default Link ID Prefix: A prefix can be typed in here that will be added to each link. The
Preferences.dpf file sets the prefix as P-. A number will be added to the prefix when the link is
defined. Subsequent links will be numbered sequentially.

Link Profile Options:

Design Optimization: When designers define links, they have the option of establishing a
pipe profile envelope based on constraints on maximim and minimum crown and invert
elevations. The options below allow designers to set Geopak Drainage to design pipe based
on the pipe profile envelope.

Minimize Pipe Size: This option uses the entire envelope to size pipes by adjusting pipe
slope to minimize pipe size.

Minimize Pipe Cover: This option minimizes depth of cover based on top of the
envelope, minimum soffit elevation, and the pipe fitting this slope configuration. The
Preferences.dpf file sets this as the default.

Elevation Option: The Preferences.dpf file sets this as at Actual Link End. Calculations will
be performed and labels placed based on end of the pipe at the wall face of the node.

Link Design Options:

Design for Maximum Capacity: This option sizes pipe using maximum capacity, which
occurs at less than full flow.

Design for Full Capacity: This option sizes pipe using full flow. This is the procedure used
in Section 4A-10. The Preferences.dpf file sets this as the default.

Design Partial Capacity (d/D) Ratio: The ratio of depth of flow to diameter of pipe is used to
size pipe. The designer chooses the ratio.

Design Partial Capacity (q/Q) Ratio: The ratio of discharge to pipe capacity is used to size
pipe. The designer chooses the ratio.

Link Slope Decimal: This sets the number of decimal places reported for link (pipe) slopes.
Link Criteria File: Name of criteria file used to draw links onto cross sections.

Hydraulic GradelLine Options/Hydraulic Gradeline Basis: The Preferences.dpf file sets this to
Equal Hydraulic Gradeline. This option assumes the starting downstream hydraulic gradeline
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

(HGL) is equal to the upstream HGL (plus junction losses if applicable) of the downstream link.
This is the procedure used by the Office of Design.

Profile Options
Use this dialog box to set naming convention defaults when including profiles in cross sections.

r
“ Preferences - Profile Options S

File

Options
Units [ Default Profile 10 Prefic:

Project Components [ iCreate Cogo Chains and Profiles;
Rairfall Parameters
Land Use Options
Frequency Options
Intensity Option
Junction Losses
Inlet Options

Mode Options

Link Options

Profile Options
Plan Symbology
|pdates

Save Options

| 0K | | Canesl |

Default Profile ID Prefix: Toggle on to add a prefix that will be added to each profile. A number
will be added to the prefix when the profile is defined. Subsequent profiles will be numbered

sequentially.

Create Chains and Profiles: Toggle on to store links in the GPK. The link name is used as both
the chain and profile name. Stationing starts at 0+00.
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Chapter 4—Drainage

Section 4A-52—Starting a Geopak Drainage Project

Plan Symbology

The Plan Symbology dialog box is used to establish element symbology for drawing drainage
features. Currently, the Office of Design has symbology prepared for Pipes, Inlets, Junctions,
Outlets, and Other. The Preferences.dpf file sets symbology as follows:

Pipes Inlets, Outlets, & Other | Junctions & Outlets
Level dsnSewerStormPipe | dsnSewerStormintake dsnSewerStormUA
Color By Level By Level By Level
Style Pipe Flow By Level By Level
Weight By Level By Level By Level

To change Linear symbology, double-click in the feature box to open the Set Feature dialog box
(example shown is for Pipes).

# Preferences - Plan Symbology

2%

| —

|'1

File

Options

Lnits

Project Components
Rainfall Parameters
Land Use Options
Frequency Options
Intensity Option
Junction Losses
Inlet Options

Mode Options

Link Options

Profile Options
Flan Symbology
|pdates

Save Options

| oK | |Cance||

Plan View Parameters

Component Linear Text

Areas:
Fipes:
Ditches:

Culverts:

Modes

Inlets:
Junctions:
Outlets:
Other:

Headwall: - Lample

Label  houble-click in

here to change
linear symbology

Double-click in
here to change
text symbology

Set Feature

Symbology
level: |dsnSewerStomPipe  ~ |
Color: [ Bylevel - |
Style: |F‘ipe Flow - |

Weight: | (10} BylLe ~ |

-
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

To set Text symbology, double-click in the feature box to open the Set Feature dialog box. The
Preferences.dpf file sets text symbology to a non-plotable level.

Set Feature -
Symbology
L evel: [dsnNonFlotable - |
Color: [M Bylevel |
Weight: [———— (0) ByLeve = |
Text Preferences

Set Justfication
Th: | 8.000 a
Tw: | 8.000

Ft: (23 0STANDARD - |

Use Geopak Labeler to label the components and nodes when the design is finished.

Updates

Use this dialog box to establish what data is updated automatically during the design process. The
Preferences.dpf file toggles all these options on as the default.

F
e e

File

Options |
Units Automatic Link Updates on Node Relocations
Project Components
Rainfall Parameters Automatic Update Area data on Network Design
Land Use Options
Frequency Options
Irrtengrt'_.r Option Automatic Update Link data on Metworke Design
Junction Logses
Inlet Options Automatic Update Profiles on Network Design
Mode Options
Link Options Automatic Update Metwork on Profile Edit
Profile QOptions
Plan Symbology
|pdates

Save Options

Automatic Update Node data on Metwors Design

| oK | [ Cancel |
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

Save Options

This dialog box is used to set the designer’s save options.

nP:Eferencs—Save Opticn: EEL
File

Options |
Units Automatically Save Drainage Updates
Project Companents
Rainfall Parameters Automnatic Backup
Land Use Options
Frequency C?::tinns Automatic Save:
Intensity Option
Junction Losses
Inlet Options
MNode Options
Link Options
Profile Options
Plan Symbology
|Updates

Save Cptions

S Y

Automatically Save Drainage Updates: Saves the .gdf file every time an Apply command is issued
from any Drainage dialog. The Preferences.dpf file toggles this option on.

Automatic Backup: Creates a .bak file when the project is opened. Designers are advised to create
a backup file.

Automatic Save: Allows the designer to set a specified time interval to automatically save the .gdf
file.

The project has been setup. Click OK and save your changes.
Exit Geopak Drainage by going to Drainage->Project-> Exit

Reopen Geopak Drainage by going to Drainage->Project->Open

Printing Project Preferences

Designers can print project preferences by going to Project->Export->Preferences to ASCII.

P DRAINAGE - Cheslea

Component  Metwork Reports  Utilities  Tool Boxes

Preferences

Drainage Library

Import
Export To Metwork...
To SWMMS...

Exit

~DesigniDrainage\Cheslea Creek.gdf Preferences to ASCII
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Chapter 4—Drainage Section 4A-52—Starting a Geopak Drainage Project

This will create a .drp file which can be opened using MicroSoft Word.
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Chronology of Changes to Design Manual Section:

004A-052

5/9/2017

11/30/2011

9/30/2011

7/29/2011

Starting a GEOPAK Drainage Project

Revised
Revised several screen shots and file references to reflect move to ProjectWise.

Revised
Correct graphic under Junction Losses - should show Method 2 for Simple Junction and Complex Junction

Revised
Changed plan symbology for pipes. Change juction loss defaults for simple and complex joints to Method 2.

NEW
New
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